Задание: составить программу, в которой посчитать кол-во гласных в строке. (в pascal)
(тема: двумерные массивы)
Ответы на вопрос
Ответил raf1O5
0
program raf105;
var a:array[1..100,1..2] of char;
glas,s:string;
i,j,sumglas:integer;
begin
glas:='аеёиоуыэюя'; // Перечисление гласных
for i:=1 to length(glas) do
a[i,2]:= glas[i]; //Заполнение второй строки для гласных
writeln('Введите строку');
readln(s);
for i:=1 to length(s) do
a[i,1]:= s[i]; //Заполнение первой строки для введённых букв
for i:=1 to length(s) do
for j:=1 to length(glas) do
if a[i,1] = a[j,2] //если символ из строки 1 = символу из строки 2
then sumglas:= sumglas+1; //Прибавление единицы к счётчику
writeln('В строке ',sumglas,' гласных');
end.
Ответил ClarisVerbis
0
а если тип данных integer? var a:array[1..100,1..2] of integer
Ответил raf1O5
0
integer принимает только числа
Ответил raf1O5
0
Будет ошибка
Ответил raf1O5
0
Т.к. строка состоит из символов, то в массивах нужно использовать тип char (символьный тип)
Ответил ClarisVerbis
0
если у Вас есть время https://znanija.com/task/32357980
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Обществознание,
7 лет назад
Алгебра,
7 лет назад
Биология,
9 лет назад