Информатика, вопрос задал daryakuzovkova99 , 2 года назад

Задание Python 2_6:

Найдите все трѐхзначные и четырѐхзначные числа Армстронга.

Число Армстронга. Числом Армстронга считается натуральное число, сумма цифр которого,

возведенных в N-ную степень (N – количество цифр в числе) равна самому числу.

Например, 153 = 13 + 53 + 33

.

Задание Python 2_7:

Напишите программу, которая запрашивает натуральное число N и выводит на экран

все автоморфные числа, не превосходящие N.

Автоморфным называется натуральное число, если оно равно последним цифрам своего

квадрата. Например, 252 = 625.

rint ("всё!")

Задание Python 4: Составить программу для вычисления среднего

арифметического N произвольных вводимых чисел.



Задание Python 5: Исправить предыдущее задание (2_4) для работы со случайными

числами.​

Ответы на вопрос

Ответил maks555201568
1

Ответ:Задание 4

summ, n = 0, int(input())

for _ in range (n):

   summ += int(input())

float(summ)

print(summ / n)

Задание 5

summ, n = 0, int(input())

from random import randint

for _ in range (n):

   summ += randint(0, 100)

float(summ)

print(summ / n)

Задание 2_6

for i in range(100,1000):

   sum = 0

   for s in range(0, 3):

       i = str(i)

       sum = sum + int(i[s]) ** 3

       i = int(i)

   if sum == i:

       print(i)

Задание 2_7

n = int(input())

for i in range(n):

   if i * i % (10 ** len(str(i))) == i :

       print(i)

Объяснение:

В задании 5, в "random.randint(0,100)" необзательно эти числа, спроси у учителя какой должен быть интервал(тут от 0 до 100) и впиши нужные числа

Новые вопросы