Задание по программированию на С++
Написать программу, которая будет выводить на экран: «Введи свой возраст», затем считывать введенное с клавиатуры целое число и выводить на экран правильно законченную фразу: «Вам !число! год/года/лет», если число находиться в промежутке (1-130), обработать возможные ошибки
Ответы на вопрос
Ответил MrMiner1
0
#include <iostream>
using namespace std;
int main(){
setlocale(LC_ALL, "Russian");
cout<<"Введи свой возраст"<<endl;
int a;
cin>>a;
if (a<1||a>130){cout<<"Введено некорректное значение"; return 0;}
if (a%100==11||a%100==12||a%100==13||a%100==14){cout<<"Вам "<<a<<" лет"; return 0;}
if (a%10==1){cout<<"Вам "<<a<<" год"; return 0;}
if (a%10==2||a%10==3||a%10==4){cout<<"Вам "<<a<<" года"; return 0;}
cout<<"Вам "<<a<<" лет";
return 0;
}
_________
Есть еще возможность проверки принадлежности введеной строки к числовому типу. Но, просматривая уровень ваших заданий, я пришел к выводу, что функции такого уровня будут не совсем желательны. Если все-же нужна - пишите.
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Геометрия,
7 лет назад
Геометрия,
7 лет назад
Химия,
9 лет назад
Математика,
9 лет назад