Задание по Паскалю
Дан массив из 4х4 вещественных (дробных) чисел. Напишите программу вычисления суммы квадратов дробных частей у элементов массива стоящих выше главной диагонали.
Ответы на вопрос
Ответил fovfabomi
0
var a:array [1..4,1..4] of real;
i,j:integer;
s:real;
begin
for i:=1 to 4 do
for j:=1 to 4 do readln(a[i,j]);
for i:=1 to 4 do
for j:=1 to 4 do if j>i then s:=s+sqr(frac(a[i,j]));
writeln(s);
end.
vksaharkov:
Если правильно, то спасибо огромное))
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Русский язык,
2 года назад
Физика,
2 года назад
Математика,
8 лет назад