Информатика, вопрос задал Kearke , 2 года назад

Задание на python
Напишите программу, которая считывает одно число n с ввода и выводит пирамидку от 1 до n.

Sample Input:

5
Sample Output:

1
1 2
1 2 3
1 2 3 4
1 2 3 4 5

Ответы на вопрос

Ответил timkafey
1

n = int(input())

for i in range(1, n + 1):

 line = ''

 for z in range(1,i + 1):

   line += str(z)

 print(line)


Kearke: Мне пробелы нужны между цифр
Ответил restIess
1

n = int(input())

for i in range(1,n+1):

   for j in range(1,i+1):

       print(j,end=' ')

   print()

Новые вопросы