Информатика, вопрос задал Abuhir , 9 лет назад

Задание 3
Составить программу, выводящую время года в зависимости от номера месяца введенного пользователем.

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  case ReadInteger('Номер месяца (1-12):') of
  1,2,12:Writeln('Зима');
  3..5:Writeln('Весна');
  6..8:Writeln('Лето');
  9..11:Writeln('Осень');
  else Writeln('Неверный номер месяца')
  end
end.

Вариант "для школьников"
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
var n:integer;
begin
  Write('Номер месяца (1-12): '); Read(n);
  case n of
  1,2,12:Writeln('Зима');
  3..5:Writeln('Весна');
  6..8:Writeln('Лето');
  9..11:Writeln('Осень');
  else Writeln('Неверный номер месяца')
  end
end.

Ответил A1dar
0
Можно так: writeln(copy('Зима Весна Лето Осень', ReadInteger mod 12 div 3 * 6, 5))
Ответил Аноним
0
Во-первых, по 9..11 выдается "сень", а во-вторых (хоть это и несущественно), на значения вне [1;12] реагирует внешне довольно странно, хотя алгоритмически объяснимо.
Ответил A1dar
0
Потому что сайт проглатывает несколько подряд идущих пробелов, перед Осень должно быть 2 пробела
Ответил A1dar
0
Для значений [1;12] работает отлично
Новые вопросы