Задание 3. Массив содержит значения стоимости 20 товаров в магазине (случайные числа от 10 до 30). Составьте программу, которая определяет стоимость этих товаров после 15%-й скидки и выводит на экран исходный и преобразованный массивы.
Пожалуйста, на языке паскаль
Ответы на вопрос
Ответ:
Вот программа на языке Паскаль, которая выполняет заданную задачу:
program Discount;
uses crt;
var
prices: array[1..20] of real;
discounted_prices: array[1..20] of real;
i: integer;
begin
randomize;
writeln('Исходные цены:');
for i := 1 to 20 do
begin
prices[i] := random(21) + 10; // случайные числа от 10 до 30
writeln(prices[i]:0:2);
end;
writeln('Цены после скидки:');
for i := 1 to 20 do
begin
discounted_prices[i] := prices[i] * 0.85; // применяем 15%-ую скидку
writeln(discounted_prices[i]:0:2);
end;
end.
Эта программа создает массив prices со случайными значениями от 10 до 30, затем применяет 15%-ную скидку к каждому элементу массива и сохраняет результаты в массив discounted_prices. Затем она выводит исходные и преобразованные массивы на экран. Пожалуйста, учтите, что функция random генерирует случайные числа в диапазоне от 0 до указанного значения минус один, поэтому мы добавляем 10, чтобы получить диапазон от 10 до 30. Кроме того, мы умножаем исходные цены на 0.85, чтобы применить скидку в 15%.