Информатика, вопрос задал irinagerko40 , 1 год назад

Задание 3. (7-8 балов)
Составьте программу, которая заполняет массив а [110]
случайными целыми числами в диапазоне от 0 до 20 и находит ко-
личество элементов, которые больше своего предыдущего соседа
слева.

Ответы на вопрос

Ответил sashok451
0

import random

# Создаем массив a с 110 элементами, заполняем случайными числами от 0 до 20

a = [random.randint(0, 20) for _ in range(110)]

# Инициализируем счетчик количества элементов, больших предыдущего соседа слева

count = 0

# Перебираем элементы массива, начиная со второго элемента

for i in range(1, len(a)):

   if a[i] > a[i - 1]:

       count += 1

# Выводим результат

print("Массив a:", a)

print("Количество элементов, больших предыдущего соседа слева:", count)

Новые вопросы