Информатика, вопрос задал chernovannastya , 6 лет назад

Задание 3 (35 баллов).

Составить программу на языке Паскаль для решения следующей задачи:

Дан одномерный массив. В массиве хранятся оценки по информатике учеников 9 класса. Заполнить массив случайными числами, лежащими в диапазоне от 2 до 5 включительно. Вычислите среднюю оценку в классе по информатике. Входные данные для размерности массива задайте самостоятельно.

На проверку нужно прислать текст кода программы, результат работы кода в виде скриншота окна программы с отображением кода и полученного результата. Программная реализация обязательна!

Ответы на вопрос

Ответил zromaz2007
1

Ответ:

const Sz = 100;

var

 a: array [1..Sz] of integer;

 N: integer;//длина массива

 i, sum: integer;

begin

 N := 20;

 sum := 0; // сумма

 for i:=1 to N do

   a[i] := Random(2, 5); // заполняем числами от 2 до 5

 for i:=1 to N do

   sum := sum + a[i];

   write(sum/n); // считаем среднее

end.

Объяснение:


chernovannastya: Сто проц правильно?
chernovannastya: Есть ошибка.
zromaz2007: nf
zromaz2007: где?
chernovannastya: дай вк или что-то из этого
Новые вопросы