Информатика, вопрос задал b6ksd62pp8 , 1 год назад

Задание 2
Разработайте блок-схему алгоритма и программу на языке Паскаль или Руоп для решения задачи.
Определите количество и сумму нечетных чисел, кратных 7, на интервале [100; 200].
На проверку нужно прислать блок-схему алгоритма, текст кода программы, результат работы кода в виде скриншота окна программы с отображением кода и полученного результата. Программная реализация обязательна.

Ответы на вопрос

Ответил vitalyi281peromename
2

Ответ:

program OddNumbersDivisibleBy7;

var

 num, sum, count: integer;

begin

 sum := 0;

 count := 0;

 

 for num := 100 to 200 do

 begin

   if (num mod 2 <> 0) and (num mod 7 = 0) then

   begin

     sum := sum + num;

     count := count + 1;

   end;

 end;

 

 writeln('Количество нечетных чисел, делящихся на 7 на отрезке [100; 200] ', count);

 writeln('Сумма нечетных чисел, делящихся на 7 на отрезке [100; 200] ', sum);

 

 readln;

end.

Объяснение:

Сначала программа инициализирует переменные sum и count равными 0. Затем она перебирает каждое целое число от 100 до 200, проверяя, является ли целое число нечетным и делится ли оно на 7. Если да, то оно добавляет целое число к sum и увеличивает count. После завершения цикла программа выводит количество нечетных чисел, кратных 7, на интервале [100; 200] (счет) и сумма этих чисел (сумма).

Новые вопросы