Информатика, вопрос задал chernovannastya , 6 лет назад

Задание 2 (35 баллов).

Составить программу на языке Паскаль для решения следующей задачи:

Дан одномерный массив. Замените все отрицательные элементы массива их квадратами, положительные элементы оставьте без изменения. Входные данные для размерности массива и значения элементов массива задайте самостоятельно.

На проверку нужно прислать текст кода программы, результат работы кода в виде скриншота окна программы с отображением кода и полученного результата. Программная реализация обязательна!

Ответы на вопрос

Ответил zromaz2007
2

Ответ:

const Sz = 100;

var

 a: array [1..Sz] of integer;

 N: integer;//длина массива

 i, sum: integer;

begin

 N := 20;

 sum := 0;

 for i:=1 to N do

   read(a[i]); // считываем

 for i:=1 to N do begin

   if a[i] < 0 then

     a[i] := a[i] * a[i]; // меняем на квадрат если меньше 0

   end;

   for i:=1 to N do

   write(a[i],' '); // вывод

end.

Объяснение:

Новые вопросы