Задание 1. Заполнение массива от a до b
Дан массив из 30 элементов. Заполнить массив начиная с элемента a до элемента b двойками, а остальные элементы нулями и вывести весь массив на экран.
Известно, что 1<=a
Формат ввода
Вводятся 2 целых числа 1<=a
Формат вывода
Массив из 30 элементов
Пример
Ввод
2 10
Вывод
0 2 2 2 2 2 2 2 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
в Паскале ABC ( не обновленном )
Ответы на вопрос
Ответил Аноним
0
Var M:array[1..30] of integer;
i,a,b:integer;
Begin
Read(a,b);
For i:= 1 to a-1 do
M[i]:=0;
For b:= a to b do
M[b]:=2;
For i:= b+1 to 30 do
M[i]:=0;
For i:= 1 to 30 do
Write(M[i],' ')
End.
i,a,b:integer;
Begin
Read(a,b);
For i:= 1 to a-1 do
M[i]:=0;
For b:= a to b do
M[b]:=2;
For i:= b+1 to 30 do
M[i]:=0;
For i:= 1 to 30 do
Write(M[i],' ')
End.
Новые вопросы
Биология,
2 года назад
Математика,
2 года назад
Литература,
8 лет назад
Математика,
8 лет назад
История,
9 лет назад