Задание 1. Дана программа нахождения суммы и произведения первых 10-и натуральных чисел
Составьте программу нахождения суммы и произведения первых 20-и четных чисел.
program pr_1;
var i, s, p: integer;
begin
s:=0;
p:=1;
for i:=1 to 10 do
begin
s:=s+i;
p:=p*i
end;
writeln ('сумма чисел равна ', s);
writeln ('произведение чисел равно ', p)
end.
program pr_2;
var i, s, p: integer;
begin
s:=0;
p:=1;
i:=1;
while i<=10 do
begin
s:=s+i;
p:=p*i;
i:=i+1
end;
writeln ('сумма чисел равна ', s);
writeln ('произведение чисел равно ', p)
end.
Ответы на вопрос
Ответил pacixor
0
//Pascal с циклом for
var i, s: integer;
p: real;
begin
s:=0;
p:=1;
for i:=1 to 20 do
if i mod 2 = 0 then
begin
s:=s+i;
p:=p*i;
end;
writeln('Сумма четных чисел: ', s);
writeln('Произведение четных чисел: ', p);
end.
//С циклом while
var i, s: integer;
p: real;
begin
s := 0;
p := 1;
i := 1;
while i <= 20 do
begin
if i mod 2 = 0 then
begin
s:=s+i;
p:=p*i;
end;
i := i + 1;
end;
writeln('Сумма четных чисел: ', s);
writeln('Произведение четных чисел: ', p);
end.
var i, s: integer;
p: real;
begin
s:=0;
p:=1;
for i:=1 to 20 do
if i mod 2 = 0 then
begin
s:=s+i;
p:=p*i;
end;
writeln('Сумма четных чисел: ', s);
writeln('Произведение четных чисел: ', p);
end.
//С циклом while
var i, s: integer;
p: real;
begin
s := 0;
p := 1;
i := 1;
while i <= 20 do
begin
if i mod 2 = 0 then
begin
s:=s+i;
p:=p*i;
end;
i := i + 1;
end;
writeln('Сумма четных чисел: ', s);
writeln('Произведение четных чисел: ', p);
end.
Приложения:

Ответил bogdan975
0
Спасибо!
Новые вопросы
Қазақ тiлi,
2 года назад
Математика,
8 лет назад
Алгебра,
8 лет назад
Обществознание,
9 лет назад
Математика,
9 лет назад