задан массив из 10 целых чисел. Написать программу которая находт
-сумму всех элементов массива
-колличество чётных и нечётных элементов массива
Ответы на вопрос
Ответил Аноним
0
const n=10;
var a:array[1..n] of integer;
i,s,k1,k2:integer;
begin
writeln('vvedite massiv=');
for i:= 1 to n do
readln(a[i]);
s:=0;
k1:=0;
k2:=0;
for i:= 1 to n do
begin
s:=s+a[i];
if a[i] mod 2=0 then inc(k1) else inc(k2);
end;
writeln('s=',s,' k1=',k1,' k2=',k2);
readln;
end.
var a:array[1..n] of integer;
i,s,k1,k2:integer;
begin
writeln('vvedite massiv=');
for i:= 1 to n do
readln(a[i]);
s:=0;
k1:=0;
k2:=0;
for i:= 1 to n do
begin
s:=s+a[i];
if a[i] mod 2=0 then inc(k1) else inc(k2);
end;
writeln('s=',s,' k1=',k1,' k2=',k2);
readln;
end.
Ответил Аноним
0
объявила
Ответил Аноним
0
Ну ты же количество чётных чисел в том же цикле проверяешь
Ответил Аноним
0
))) прости ..не врубилась .....
Ответил Аноним
0
=)))
Новые вопросы