Задан двумерный массив Y из 7-и строк и 3-х столбцов. Составить программу подсчёта суммы произведений элементов строк. Pascal
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Исходный массив ***');
var a:=MatrRandom(7,3,-99,99);
a.Println(4); Writeln(4*a.ColCount*'-');
Writeln('S= ',a.Rows.Select(r->r.Aggregate(1,(x,y)->x*y)).Sum)
end.
Пример
*** Исходный массив ***
-58 86 46
-76 -50 38
35 -98 -93
-81 21 21
-20 32 -84
-80 32 -8
-8 -6 55
------------
S= 275101
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Исходный массив ***');
var a:=MatrRandom(7,3,-99,99);
a.Println(4); Writeln(4*a.ColCount*'-');
Writeln('S= ',a.Rows.Select(r->r.Aggregate(1,(x,y)->x*y)).Sum)
end.
Пример
*** Исходный массив ***
-58 86 46
-76 -50 38
35 -98 -93
-81 21 21
-20 32 -84
-80 32 -8
-8 -6 55
------------
S= 275101
Новые вопросы