Информатика, вопрос задал timurdzumanov14 , 2 года назад

Задачи
«В»: Напишите программу, которая заполняет матрицу
случайными числами и находит максимальный
элемент матрицы и его индексы (номера строки и
столбца).
Пример:
Матрица А:
12 34 14 65
71 88 23 98
87 46 53 39
76 58 24 92
Максимум: A[2, 4] = 98

Приложения:

Jason785: какой язык?
timurdzumanov14: pathon
timurdzumanov14: пожалуйста помогите решить .
timurdzumanov14: если хотите я могу на вас подписаться .
timurdzumanov14: простите что так долго не отвечал .
timurdzumanov14: пожалуйста помогите
timurdzumanov14: пожалуйста помогите решить эту задачу

Ответы на вопрос

Ответил nastikots
0

Ответ:

import random

a = [0] * 4  

for i in range(4):  

   a[i] = [0] * 4

mi = 1

mj = 1

print("Матрица A:")

for i in range (4):

   for j in range (4):

       a[i][j] = random.randint(10,99)

       if a[i][j]>a[mi][mj]:

           mi = i

           mj = j

       print("%3d" % (a[i][j]),end="")

   print()

print("Максимум: A[{0},{1}] = {2}".format(mi+1,mj+1,a[mi][mj]))

Объяснение:

Создаём матрицу заполненную 0

Задаём начальные значения максимальных индексов

Заполняем матрицу случайными числами, ищем максимальные индексы и выводим элементы на экран

Выводим максимальные индексы и значение элемента

Приложения:

timurdzumanov14: спасибо огромное
Новые вопросы