Задачи. Написать программу, которая:

Ответы на вопрос
#include<iostream>
#include<conio.h>
void pervoe(int number){
std::cout<<"Сумма квадратов первой и последней цифры числа "<<number<<" равна "<<(number/10000)*(number/10000)+(number%10)*(number%10)<<std::endl;
}
void vtoroe(int number){
int sum = 1,t=number;
for(short i=0;i<6;i++){
sum*=t%10;
t/=10;
}
std::cout<<"Результат: "<<number/1000<<sum<<number%1000<<std::endl;
}
void tretye(int number){
int sum = 0,t=number;
for(short i=0;i<3;i++){
sum+=t%10;
t/=10;
}
std::cout<<"Результат: "<<number%sum<<std::endl;
}
int enter(void){
int a;
std::cout<<"Введите число:"<<std::endl;
std::cin>>a;
return a;
}
int main(){
setlocale(0,"");
bool exit = true;
while(exit){
std::cout<<"Сумма квадратов первой и последней цифры пятизначного числа - Клавиша 1"<<std::endl<<
"Вычисление произведения цифр шестизначного числа и помещение его же в середину этого же числа - Клавиша 2"<<std::endl<<
"Остаток от деления трёхзначного числа на сумму его цифр - Клавиша 3"<<std::endl<<
"Выход - Esc"<<std::endl;
switch(getch()){
case 27:
exit=false;
break;
case 49:
pervoe(enter());
break;
case 50:
vtoroe(enter());
break;
case 51:
tretye(enter());
break;
}
}
}
Немного подшаманил с вводом, костыльно, но работает при нормальной эксплуатации.