Информатика, вопрос задал nafpolu05 , 2 года назад

Задачи «Цикл с предусловием»
1 Напишите программу, в которой осуществляется ввод целых чисел (ввод
осуществляется до тех пор, пока не будет введён ноль) и подсчёт суммы
и среднего арифметического введённых положительных чисел.
2 Напишите программу, в которой осуществляется ввод целых чисел (ввод
осуществляется до тех пор, пока не будет введён ноль) и определение
максимального (наибольшего) из введённых чисел.

Ответы на вопрос

Ответил andrewus04
1

Ответ:

Объяснение:

Язык не был указан, так что пишу на С++:

1)

#include <iostream>

using namespace std;

int main()

{

   int buf, quantity = 0;

   cin >> buf;

   int sum = 0;

   while (buf != 0) {

       ++quantity;

       sum += buf;

       cin >> buf;

   }

   cout << "Sum: " << sum << "\nAverage: " << sum / quantity;

}

2)

#include <iostream>

using namespace std;

int main()

{

   int buf;

   cin >> buf;

   int max_num = buf;

   while (buf != 0) {

       if (max_num < buf) {

           max_num = buf;

       }

       cin >> buf;

   }

   cout << "Max: " << max_num;

}

Новые вопросы