Информатика, вопрос задал tsgbeghnethn , 9 лет назад

Задача в Pascal!!!!!!
Том Сойеру необходимо покрасить забор с двух сторон, который содержит N досок. Размеры каждой доски А * В (в метрах). На каждый квадратный метр доски расходуется С кг краски. Каждая банка содержит D кг. Помогите Тому Сойеру определить количество банок краски, которые ему потребуются для покраски забора.
Входные данные:
Во входном потоке в первой строке через пробел заданы пять целых чисел (N, A, B, C, D <= 1000).

Выходные данные:
Вывести единственное число.

Пример входного файла (input.txt):
10 1 1 2 3

Ответы на вопрос

Ответил Аноним
0
var
  A, B, C, D, N, V, K, M: integer;
  F: Text;

begin
  Assign(f,'input.txt');
  Reset(f);
  Readln(N,A,B,C,D);
  Close(f);
  V := A * B * N;
  if V mod C <> 0 then
    K := V div C + 1
  else
    K := V div C;
  if K mod D <> 0 then
    M := K div D + 1
  else
    M := K div D;
  writeln(M)
end.

Тестовое решение:

2

Ответил andre2k17
0
во-первых, забор нужно с двух сторон покрасить, во-вторых ответ 14
Ответил andre2k17
0
так что решение не верно...
Новые вопросы