Задача в Pascal abc.
Подсчитать количество двузначных чисел, которые кратны 3
ZMBK:
Составить программу
Ответы на вопрос
Ответил MaryzYen
0
12, 15, 18, 21, 24, 27, 30, 33, 36, 39, 42, 45, 48, 51, 54, 57, 60, 63, 66, 69, 72, 75, 78, 81, 84, 87, 90, 93, 96, 99. Итого 30.
Ответил 65536
1
const
start=12; //наименьшее подходящее число
max=100; //первое число, идущее после всех двузначных
step=3; //разность между подходящими числами
var
x,i:integer;
begin
x:=start;
i:=0;
while x<max do begin
i:=i+1;
x:=x+step;
end;
writeln('Количество искомых чисел: ',i);
end.
start=12; //наименьшее подходящее число
max=100; //первое число, идущее после всех двузначных
step=3; //разность между подходящими числами
var
x,i:integer;
begin
x:=start;
i:=0;
while x<max do begin
i:=i+1;
x:=x+step;
end;
writeln('Количество искомых чисел: ',i);
end.
Новые вопросы
Английский язык,
2 года назад
Окружающий мир,
2 года назад
Математика,
2 года назад
Русский язык,
2 года назад
Математика,
7 лет назад