Информатика, вопрос задал cerfateev133 , 9 лет назад

Задача в delphi. Составить программу для нахождения суммы: 2!+3!+4!+...+N!

Ответы на вопрос

Ответил GrimAnEye
0
//Создать консольное приложение
program ConsoleProgram; 
{$APPTYPE CONSOLE}
var valueN,sum,i,i2,tmp:longint;
begin
sum:=0;
readln(valueN);
for i:=1 to valueN do
begin
tmp:=1;
for i2:=1 to i do
tmp:=tmp*i2;
sum:=sum+tmp;
end;
writeln(sum);
readln;
end.
Новые вопросы