Задача по языку программирования Pascal
n школьников делят k яблок “поровну”, то есть так, чтобы количество яблок, доставшихся любым двум школьникам, отличалось бы не более, чем на 1.
Входные данные
Программа получает на вход числа n и k.
Выходные данные
Программа должна вывести количество школьников, которым достанется яблок меньше, чем некоторым из их товарищей.
Ответы на вопрос
Ответил danulpopov
0
// PascalABC.NET 3.3, сборка 1576 от 16.11.2017
// Внимание! Если программа не работает, обновите версию!
Begin
var (n, k) := ReadInteger2('Введите n и k');
Writeln(k - (k div n) * n);
end.
// Внимание! Если программа не работает, обновите версию!
Begin
var (n, k) := ReadInteger2('Введите n и k');
Writeln(k - (k div n) * n);
end.
Ответил HelgaHolod
0
Можно ли ещё вопрос?
Ответил danulpopov
0
var n,k,x:integer;
begin
readln(n,k);
x:=k-n mod k;
writeln('x=',x);
end.
begin
readln(n,k);
x:=k-n mod k;
writeln('x=',x);
end.
Ответил HelgaHolod
0
Совсем неправильно
Ответил HelgaHolod
0
Ни один тест не прошло...
Ответил danulpopov
0
хмм,..может потому, что там фаловый ввод вывод?
Новые вопросы