Информатика, вопрос задал fanntomde1 , 6 лет назад

Задача по информатике Python:
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — максимальное число, кратное 4. (30Б)

Ответы на вопрос

Ответил rootправа
0

Ответ:

Объяснение:

import random

s = []

for x in range(1001):

   s.append(random.randint(1, 30000))

ans=[]

for i in s:

   if i%4==0:

       ans.append(i)

print(max(ans))

Приложения:
Новые вопросы