Информатика, вопрос задал whoooo , 7 лет назад

Задача No3
Составить программу разложения натурального числа n на простые множители.
пример: 360 = 2 2 2 3 3 5. Посчитать количество разных множителей.
our
python цикл while​

Ответы на вопрос

Ответил Omikami
0

n = int(input())

divisor = 2

unique = set()

while n > 1:

   if n % divisor == 0:

       print(divisor, end=' ')

       unique.add(divisor)

       n //= divisor

   else:

       divisor += 1

print('nКоличество уникальных делителей: {0}'.format(len(unique)))

Новые вопросы