Информатика, вопрос задал alenaemelyanov2 , 7 лет назад

Задача: написать программу нахождение наибольшего числа из 4 любых.
Сейчас изучаем паскаль

Ответы на вопрос

Ответил DimaLML
0

var


   a1, a2, a3 a4 max: integer;


 

begin


   write ('Введите 4 числа: ');


   readln (a1, a2, a3, a4);


 

   if a1 >= a2 then


       max := a1


   else


       max := a2;


 

   if a2 > a3 then

       max := a2;


if a3>a4 max then

max:=a4

 

   writeln ('Максимальное из них: ', max);


 

readln


end.

Ответил DimaLML
0
Косяк мой,после этой строки еще строка max := a4;
Ответил DimaLML
0
var

a1, a2, a3 a4 max: integer;



begin

write ('Введите 4 числа: ');

readln (a1, a2, a3, a4);



if a1 >= a2 then

max := a1

else

max := a2;



if a2 > a3 then

max := a2;

if a3>a4 max then



writeln ('Максимальное из них: ', max);



readln

end.
Ответил DimaLML
0
begin

write ('Введите 4 числа: ');

readln (a1, a2, a3, a4);

if a1 >= a2 then

max := a1

else

max := a2;

if a2 > a3 then

max := a2;

if a3>a4 max then

max:=a4;

writeln ('Максимальное из них: ', max);

readln

end.

Вот это верный код
Ответил alenaemelyanov2
0
Спасииибо:з
Новые вопросы