Информатика, вопрос задал MataMasek1 , 2 года назад

Задача на Python, С любой:
На этой неделе на уроках информатики Васе рассказывают про строки.

Вчера Вася узнал, что такое циклический сдвиг:

k-й циклический сдвиг строки – это строка, полученная перестановкой первых k символов строки в её конец. В частности, 0-й циклический сдвиг строки – это сама строка.

И он написал программу, которая умеет перемещать первый символ строки в её конец k раз, получая таким образом k-й циклический сдвиг строки.

Сегодня Васе нужно реализовать разворот строки. Но у Васи тренировка. Ему некогда писать новые сложные программы. Поэтому он задался вопросом:

Можно ли циклическими сдвигами развернуть строку?

Благодаря своим друзьям Вася узнал, на какой строке (да, всего одной) будет тестировать его программу учитель, у которого нет времени рецензировать код каждого ученика. Поэтому вопрос упростился:

Можно ли циклическими сдвигами развернуть строку s?

Помогите ему ответить на этот вопрос.

Формат входных данных

Первая строка содержит одно целое число n (1≤n≤3⋅105) – длина строки s.

Во второй строке – сама строка s, на которой будет тестировать программу Васи учитель. Состоит строка s только из строчных латинских букв.

Формат выходных данных

Если строку нельзя развернуть циклическими сдвигами, то выведите число −1. В противном случае выведите такое целое число k (0≤k
Пояснение к примеру

0-й циклический сдвиг строки s равен abac.

1-й циклический сдвиг строки s равен baca.

2-й циклический сдвиг строки s равен acab.

3-й циклический сдвиг строки s равен caba.

Развёрнутая строка s равна caba.

Единственное подходящее k равно трём.

Sample Input:

4
abac
Sample Output:

3

Ответы на вопрос

Ответил yurban20023
4

Ответ:

a=int(input())

slovo=input()

count=0

slovo2=slovo[::-1]

if slovo==slovo2:

   count=0

else:

   while slovo!=slovo2:

       if count>=a:

           count=-1

           break

       word=slovo[:1]

       slovo=slovo[1:]

       slovo+=word

       count+=1

print(count)

Объяснение:на Е1 и Е2 подойдет, на е3 нет

Новые вопросы