Информатика, вопрос задал lilamoon , 2 года назад

Задача на питоне.


Входные данные

Вводится число N. Дальше вводится массив целых чисел из N элементов.


Выходные данные

Выведите количество элементов, которые больше предыдущего.


Пример:

Входные данные

6

1 2 3 2 5 1


Выходные данные:

3


Примечание

В примере второй элемент больше первого ( 1<2), третий элемент больше предыдущего (2<3) и пятый элемент больше предыдущего (2<5). Всего элементов, больших предыдущего ровно 3

Ответы на вопрос

Ответил vimmortal2
1

Программа:
Python:

N, arr, amount = int(input()), [], 0

for i in range(N):

   arr.append(int(input()))

for i in range(len(arr)):

   if i != 0 and arr[i] > arr[i - 1]:

       amount += 1

print(amount)

Объяснение:

В начале регистрируются три переменные:

  • Переменная N - хранит целое число. Это количество элементов массива.
  • Переменная arr - хранит массив. Это массив введённых с клавиатуры чисел.
  • Переменная amount - хранит целое число. Это количество элементов массива, которые больше предыдущего числа.

Далее, с помощью цикла for выполняется тело цикла N раз: вводится число, которое получает целочисленный тип данных, и это число добавляется в конец массива arr.

Второй цикл. Он выполняется также N раз (или же len(arr) раз - длина массива arr). Если i не равно нулю (т.е. это не первое число массива) И текущий элемент (i) больше предыдущего (i - 1), увеличиваем значение переменной amount на единицу. В конце выводится amount.

Результат:

6

1

2

3

2

5

1

3

#SPJ1


lilamoon: спасибо большое!
Новые вопросы