Информатика, вопрос задал TABCHIK , 9 лет назад

Задача на Pascal
Требуется определить, бьет ли конь, стоящий на клетке с указанными координатами (номер строки и номер столбца), фигуру, стоящую на другой указанной клетке.

Входные данные
Вводятся четыре числа: координаты коня и координаты другой фигуры. Все координаты - целые числа в интервале от 1 до 8.

Выходные данные
Программа должна вывести слово YES, если конь может побить фигуру за 1 ход, в противном случае вывести слово NO.
входные данные
1
1
3
2
выходные данные
YES
входные данные
1
1
3
3
выходные данные
NO

Ответы на вопрос

Ответил Aillianna
0
var
    x1, y1, x2, y2: integer;

begin
    readln(x1, y1, x2, y2);
    
    if abs(x1 - x2) + abs(y1 - y2) = 3 then
        writeln('YES')
    else
        writeln('NO');
end.
Новые вопросы