Информатика, вопрос задал Alexandravey , 10 лет назад

Задача на циклы,пожалуйста,напишите программу Составьте программу определения наибольшего общего делителя двух натуральных чисел. (3 балла)

Ответы на вопрос

Ответил MrsSima
0

Используем стандартный алгоритм нахождения Нод.

Program n1;
Uses CRT;
Var a,b,c: integer;
begin
ClrScr;
Writeln('Vvedite A i B');
Readln(a,b);
while b<>0 do
begin
c := a mod b;
a := b;
b := c;
end;
writeln('NOD =',a);
readln
end.

Новые вопросы