Информатика, вопрос задал mikrob4928 , 1 год назад

Задача на C++
Нужно написать программу наибольший общий делитель и наименьшее общее кратное двух чисел

Ответы на вопрос

Ответил romatsupa
1

Ответ:

#include<bits/stdc++.h>

using ll = long long;

using namespace std;

#define endl '\n'

int gcd (int a, int b) {//НОД

return b ? gcd (b, a % b) : a;

}

int lcm (int a, int b) {//вычисление НОК также можно сделать с помощью алгоритма Евклида:

return a / gcd (a, b) * b;

}

int main()

{

   ll a, b;

   cin>>a>>b;

   cout<<gcd(a, b)<<endl;//НОД

   cout<<lcm(a, b)<<endl;//НОК

   return 0;

}


mikrob4928: спасибо очень помогли
mikrob4928: пожалуйста напишите что это означает #define endl '\n'
romatsupa: Это можно убрать, но это может ускорить программу, т.к. '/n' это более шустрый перевод строки на следующий.
romatsupa: Можете пожалуйста отметить как лучший ответ?
mikrob4928: да конечно, но когда кнопка появится
mikrob4928: можете пожалуйста прокомментировать эти строки int gcd (int a, int b) {//НОД
return b ? gcd (b, a % b) : a;
} int lcm (int a, int b) {

return a / gcd (a, b) * b;

} ,потому что я не понимаю что они выполняют
Новые вопросы