Информатика, вопрос задал mikrob4928 , 1 год назад

Задача на C++
Нужно написать программу факторизаЦИЯ (не факториал) числа


mikrob4928: Факторизация – это разложение заданного числа на простые множители.

Ответы на вопрос

Ответил Literatorhelp
1

#include <iostream>

using namespace std;

void factorize(int n) {

   cout << "The factors of " << n << " are: ";

   for (int i = 2; i <= n; i++) {

       while (n % i == 0) {

           cout << i << " ";

           n /= i;

       }

   }

   if (n > 1) {

       cout << n;

   }

}

int main() {

   int n;

   cout << "Enter a positive integer: ";

   cin >> n;

   factorize(n);

   cout << endl;

   return 0;

}

Пробуй так будут вопросы пиши


mikrob4928: спасибо все супер, прокомментируйте пожалуйста что делает эта строчка factorize(n)
Literatorhelp: В данном коде функция factorize(n) принимает целое положительное число n и выводит все его простые множители (факторизацию) на экран. Она использует циклы и операцию остатка от деления % для поиска множителей и деления числа n на них, пока не будет получен 1. Если n больше 1 после цикла, она выводит оставшийся множитель.
mikrob4928: вау, спасибо
mikrob4928: здравствуйте, могли бы вы мне помочь еще раз
mikrob4928: https://znanija.com/task/52037779
Новые вопросы