Задача на c++
Необходимо написать программу, которая вычислит сумму
2/3+3/4+4/5+...+n−1n.
Формат входных данных
Вводится натуральное число N (3≤N≤105).
Формат выходных данных
Программа должна вывести результат вычисления одним вещественным числом с точностью до шести знаков после запятой.
Ответы на вопрос
Ответил petyaGavrikov
0
#include <iostream>
using namespace std;
int main()
{
int n;
double s=0;
cout << "n = ", cin >> n, cout << "n";
for (int i=2; i<n; i++) {
s += (double)i/(i+1);
}
cout.setf(ios::fixed);
cout.precision(6);
cout << "s = " << s << "n";
return 0;
}
Пример:
n = 10
s = 6.571032
using namespace std;
int main()
{
int n;
double s=0;
cout << "n = ", cin >> n, cout << "n";
for (int i=2; i<n; i++) {
s += (double)i/(i+1);
}
cout.setf(ios::fixed);
cout.precision(6);
cout << "s = " << s << "n";
return 0;
}
Пример:
n = 10
s = 6.571032
Новые вопросы