Информатика, вопрос задал mityxcv7 , 2 года назад

Задача: Дано целое число N. Написать программу, заменяющую его нулем, если число меньше нуля и увеличивающую его на 4, если число больше либо равно нулю . В ПАСКАЛЕ .ПОМОГИТЕ ПОЖАЛУЙСТА

Ответы на вопрос

Ответил uplmtq
1

Ответ:

begin

 var N := readinteger;

 if (N < 0) then

   N := 0

 else

   inc(N, 4);

 write(N);

end.

Объяснение:

begin  // Начало программы

 var N := readinteger;  // Считываем значение переменной N с клавиатуры

 if (N < 0) then  // Если значение переменной N < 0, тогда

   N := 0  // Значение переменной N = 0

 else  // Иначе

   inc(N, 4);  // Увеличиваем значение переменной N на 4

 write(N);  // Выводим значение переменной N

end. // Конец программы


mityxcv7: спасибо
Новые вопросы