Информатика, вопрос задал mxdxze , 1 год назад

Задача C. Юбилей решите на Python
Формат входных данных
В единственной строке задано натуральное число N.
Формат выходных данных
Выведите единственное число — ответ на поставленную задачу, если он существует.
В противном случае, выведите «−1» (без кавычек).

Приложения:

Ответы на вопрос

Ответил paitanbimbim
0

def solve(x):

   # Преобразовать число в строку и разделить на отдельные цифры

   digits = list(str(x))

   # Проверить, есть ли хотя бы одна цифра 0

   if '0' not in digits:

       return -1

   # Сортировать цифры в порядке убывания

   digits.sort(reverse=True)

   # Перевести список обратно в строку и затем в число

   sorted_number = int(''.join(digits))

   # Проверить, является ли полученное число кратным 90

   if sorted_number % 90 == 0:

       return sorted_number

   else:

       return -1

# Считать входные данные

x = int(input())

# Вызвать функцию и вывести результат

result = solve(x)

print(result)

Новые вопросы