Задача 3. Напишите программу, которая в последовательности натуральных В ПАСКАЛЕ
чисел определяет произведение нечётных чисел. Программа получает на
вход количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется нечётное число. Количество чисел не
превышает 1000. Введённые числа не превышают 30000. Программа должна
вывести одно число – произведение нечётных чисел.
Ответы на вопрос
Ответил cranii
0
program main;
var n, proiz, k, a: integer; //объявление переменных
begin
proiz:=1; //начальное значение счетчика произведения
readln(n); //ввод количества чисел в последовательности
for k:=1 to n do //цикл
begin
readln(a); //ввод следующего числа
if (a mod 2<>0) then proiz:=a*proiz; // число нечётное, подсчитываем произведение
end;
writeln('proizvedenie =',proiz); //вывод произведения нечётных чисел
end.
axatar:
Тип ineger поддерживает в лучшем случае число 32767, а в условии произведение может получится равным 1000*3000= 3000000, так что прога не работает.
Новые вопросы
Английский язык,
2 года назад
Химия,
6 лет назад
Биология,
6 лет назад
Химия,
8 лет назад
Алгебра,
8 лет назад