Информатика, вопрос задал 1rimma1237 , 1 год назад

Задача 12 Вася писал программу, как вдруг компьютер выключился. Программа не сохранилась, но Вася помнит, что она выводила. Даны три запуска. Напишите программу, которая работала бы по тому же принципу, что и Васина. Nº 1 2 3 Ввод чëтные 1 нечётные 13 Вывод 4 0101 13121312 нечётные 3434​

Приложения:

Ответы на вопрос

Ответил MaxymKopychko
1

Ответ:

def foo(s, n):

   if s == 'чётные' and n % 2:

       return f'{n - 1}{n}' * 2

   elif s == 'нечётные' and n % 2:

       return f'{n}{n - 1}' * 2

   elif s == 'нечётные' and not n % 2:

       return f'{n - 1}{n}' * 2

   else:

       return f'{n}{n - 1}' * 2

print(foo(input(), int(input())))

Новые вопросы