Информатика, вопрос задал LilPupil , 6 лет назад

Задача №112168. Точка - 4
Напишите программу, которая определяет, попала ли точка с заданными координатами в заштрихованную область.
Входные данные
Входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x -координата, затем – y -координата).

Выходные данные
Программа должна вывести слово 'YES', если точка попала в заштрихованную область, и слово 'NO', если не попала.

Примеры
входные данные
0. 1.
выходные данные
NO
входные данные
0. -1.
выходные данные
YES

Приложения:

LilPupil: На c++
Леганда555: ещё нужно?

Ответы на вопрос

Ответил Леганда555
1

#include <iostream>

using namespace std;

int main() {

double x, y;

cin >> x >> y;

if (y >= x * x - 2 && (y <= x || y <= -x))

 cout << "YES";

else

 cout << "NO";

}


Леганда555: отослал на informatics, прошло все тесты
Новые вопросы