Информатика, вопрос задал Сергей211111 , 8 лет назад

Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr(x)+x/3+sqr(sin(x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3: Составить программу на языке Паскаль, которая переставляет местами цифры в двухзначном числе (например 75 заменит на 57)

Ответы на вопрос

Ответил danulpopov
0
1)
var
x:real;
begin
Readln(x);
Writeln('y = ', sqr(x)+x/3+sqr(sin(x)));
end.
2)
var
p,a,b,c:real;
begin
Readln(a,b,c);
p:= (a+b+c)/2;
Writeln('S = ', sqrt(p*(p-c)*(p-b)*(p-a)));
end.
3)
var
a:integer;
begin
Readln(a);
a:= a div 10 + (a mod 10)*10;
Writeln(a);
end.


Новые вопросы