Информатика, вопрос задал batman11032009 , 1 год назад

Задача 1 Написать программу, которая выводит все числа от 10 до 25, кроме чисел от 15 до 20 включительно. Формат вывода 10 11 12 13 14 21 22 23 24 25 решите срочно пж и вставьте решение задачи Python ​

Ответы на вопрос

Ответил VivekGarg980
2

for i in range(10, 26):

   if i < 15 or i > 20:

       print(i, end=' ')


batman11032009: спасибо
Ответил Fchchchv
4

Ответ:

numbers = list(range(10, 15)) + list(range(21, 26))

print(*numbers, sep=' ')

Объяснение:

В этом коде мы сначала создаем список чисел от 10 до 14 и от 21 до 25, используя функцию range() и конструктор list(). Затем мы объединяем эти два списка с помощью оператора +, чтобы создать новый список всех нужных чисел.

Наконец, мы используем функцию print() для вывода чисел в списке.

Синтаксис *numbers распаковывает элементы списка как отдельные аргументы функции, а аргумент sep=' ' указывает, что элементы должны быть разделены пробелом.

Надеюсь, это поможет!

Приложения:

batman11032009: спасибо первое помогло
Fchchchv: пожалуйста
Новые вопросы