Информатика, вопрос задал Давид0Гетта , 9 лет назад

За 8 класс
Решите задачу: Напишите программу, вычисляющую и выводящую на экран число бит, если задано число Мбайт. Количество Мбайт запрашивайте у пользователя программы.

Ответы на вопрос

Ответил A1dar
0
Программа на паскале:
var n: integer;
begin
  write('Введите число Мбайт: ');
  readln(n);
  write(n, ' Мбайт = ', 1024 * 1024 * 8 * n, ' бит');
end.

Ответил Аноним
0
Неверно, надо 1024*1024*8
Ответил Аноним
0
И потом, мегабайты могут быть и нецелыми.
Ответил A1dar
0
Да, в последнее время стал очень невнимательным. Спасибо за поправку. В задании не уточнили входные данные, и я принял их за целые числа
Новые вопросы