Информатика, вопрос задал qwert25 , 9 лет назад

ЯЗЫК СИ. Написать программу заполнения односвязного списка значениями и вывода этих значений. Помогите, пожалуйста.

Ответы на вопрос

Ответил greatnat
0
выбирай 

#include <stdio.h>
#include <stdlib.h>  

struct LIST {  
  int number;  
  struct LIST *next; };
  //-----------------------------------------------------------------------------
void Push(struct LIST** list, int number) {    
struct LIST* node = malloc(sizeof(struct LIST));  
  node->number = number;    
 node->next = *list;  
  *list = node; }
//-----------------------------------------------------------------------------
void Print(const struct LIST* list) {  
   if (list) {      
   Print(list->next);    
     printf("%d ", list->number);     } }
//-----------------------------------------------------------------------------  
int main() {  
  int i = 10;  
  struct LIST* list = NULL;
      while (i--) {      
  Push(&list, i + 1);     }  

//---(это разделение разных программ)
Новые вопросы