Информатика, вопрос задал vib97 , 9 лет назад

язык С !!! срочно КУЧУ БАЛЛОВ ДАЮ!!!
Составить программу, которая по формулам для арифметической
прогрессии находит сумму n первых элементов прогрессии и значения
трех элементов с номерами (n–1), n и (n+1). Число n, первый элемент и
разность прогрессии вводятся пользователем. Вывести значения
элементов в форме таблицы, где первая строка – номер, а вторая –
значение.

Ответы на вопрос

Ответил darkziablik
0
#include "stdafx.h"
#include "windows.h"
#include "locale.h"

int main(){
setlocale(0, "");

int n, a1, d, sum, A1, A2, an;

printf("Введите первый элемент прогрессии  n");

scanf_s("%i", &a1);

printf("Введите число элементов геометрической прогрессии n");

scanf_s("%i", &n);

printf("Введите разность арифметической прогрессии n");

scanf_s("%i", &d);

sum = ((2 * a1 + d*(n - 1)) / 2)*n;

an = a1 + d*(n - 1);

A1 = an - d;

A2 = an + d;

printf("Номер      An-1   An   An+1   sum n");

printf("Значение   %i      %i    %i    %i n", A1, an, A2, sum);

system("pause");

return 0;
}
Ответил darkziablik
0
спасибо, сейчас исправлю
Ответил darkziablik
0
Ну и отлично =) Надеюсь, что помог
Новые вопросы