Информатика, вопрос задал xjsgvgvhbuhyjjs , 6 лет назад

Язык Python

Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO»). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 8, или вывести «NO», если таких чисел нет. Значение выводить с точностью до десятых.

Ответы на вопрос

Ответил nester0201
4

a=1

S=0

k=0

sr=1

while a!=0:

   a=int(input())

   if a%8==0 and a!=0:

       k+=1

       S=S+a

if S==0 and k==0:

   print("NO")

else:

   sr=S/k

print(sr)

Новые вопросы