Информатика, вопрос задал rina0467 , 2 года назад

Язык Python. Даю 15 баллов.
Напишите программу, которая будет выводить, какую по счёту дощечку прибили.

Формат ввода
Сначала вводится число – сколько нужно дощечек.
Затем вводятся строки, пока не будет введена строка КОНЕЦ

Формат вывода
Строки, в которых нет слова доска или дощечка, игнорируются. Если хотя бы одно из слов есть, то выводим:
Прибили {номер} дощечку.

Как только все прибили, на дальнейший ввод не обращаем внимание и выводим:
ГОТОВО

Если не хватило, то вывести в конце:
МАЛОВАТО​

Ответы на вопрос

Ответил EcoYulia
2

Ответ:

x = int(input())

s = ''

c = 0

while s != 'КОНЕЦ':

   s = input()

   if 'доска' in s or 'дощечка' in s:

       c += 1

       print('Прибили', c, 'дощечку.')

   if c == x:

       break

if c != x:

   print('МАЛОВАТО')

else:

   print('ГОТОВО')

Объяснение:


rina0467: Спасибо большое! Всего вам самого наилучшего:D
Новые вопросы