Язык программирования С (Си)
Составить программу, анализирующую нажатую кнопку на ее принадлежность к определенной группе клавиш. Соответствующие сообщения выдаются для цифровых клавиш, больших латинских букв, малых латинских букв, больших букв и малых букв латинского алфавита
Ответы на вопрос
Ответил Аноним
2
#include<stdio.h>
#include<conio.h>
int main(int argc, char *argv[])
{
int C = getch();
if ('0'<=C&&C<='9') printf("0..9");
else if(('a'<=C&&C<='z')||('A'<=C&&C<='Z'))
printf("Latinskie%s",('a'<=C&&C<='z'?"[a..z]":"[A..Z]"));
}
#include<conio.h>
int main(int argc, char *argv[])
{
int C = getch();
if ('0'<=C&&C<='9') printf("0..9");
else if(('a'<=C&&C<='z')||('A'<=C&&C<='Z'))
printf("Latinskie%s",('a'<=C&&C<='z'?"[a..z]":"[A..Z]"));
}
Новые вопросы