Информатика, вопрос задал ninikigui , 2 года назад

язык программирования - python

Задан массив из n целых чисел. Найти количество максимальных элементов массива.

Входные данные
В первой строке записано число n (n ≤ 100). В следующей строке записано n целых чисел, не превосходящих по модулю 100.
Выходные данные
Вывести количество максимальных элементов массива.

Входные данные #1
5
1 6 2 6 2
Выходные данные #1
2​

Ответы на вопрос

Ответил robert2702
1

Ответ:

Python

Объяснение:

from random import randint

a = int(input("Введите кол-во элементов в массиве: "))

mass = [0] * a

for i in range(a):

   mass[i] = randint(1, 100)

print(mass)

max = 0

num_max = 0

for i in range(a):

   if mass[i] > max:

       max = mass[i]

for i in range(a):

   if mass[i] == max:

       num_max += 1

print("Количество максимальных элементов: ", num_max)

Новые вопросы