Информатика, вопрос задал almostepicc , 1 год назад

Язык программирования python!
Составить программу для вычисления среднего арифметического N произвольных вводимых чисел.
Формат ввода: список действительных чисел, вводимых пользователем с клавиатуры.
Формат вывода: Среднее арифметическое (действительное число).


urijbogdan3: через максимум час принимай роботу
urijbogdan3: а как оформить выход из программы , когда мы ввели все числа, и нам получить среднее арифметическое, что сделать? Или не важно?
urijbogdan3: по умолчанию сделаю так, что если вводишь 0, то вычисляет среднее арифметическое
urijbogdan3: извини, с самим Python что-то не так, когда разберусь, тогда сделаю код

Ответы на вопрос

Ответил Аноним
17

s = 0

N = int(input('Введите количество чисел в последовательности: '))

for i in range(N):

   a = int(input())

   s += a

print(s/N)

Новые вопросы