Информатика, вопрос задал Чайка2281 , 9 лет назад

ЯЗЫК ПИТОН Вася хочет узнать, какую оценку он получит в четверти по информатике. Учитель придерживается следующей системы: вычисляется среднее арифметическое всех оценок в журнале, и ставится ближайшая целая оценка, не превосходящая среднего арифметического.

При этом если у школьника есть двойка, а следующая за ней оценка – не двойка, то двойка считается закрытой, и при вычислении среднего арифметического не учитывается.

Входные данные
Вводится десять натуральных чисел от 2 до 5 через пробел – оценки Васи.

Выходные данные
Выведите натуральное число (от 2 до 5) – его четвертную оценку.

Примеры
входные данные
2 5 2 5 2 5 2 5 2 5
выходные данные
5
входные данные
2 2 2 2 2 2 2 2 2 5
выходные данные
2
входные данные
5 5 5 5 5 5 5 5 5 2
выходные данные
4
ЯЗЫК ПИТОН

Ответы на вопрос

Ответил petyaGavrikov
0
print('Введите оценки: ')
m=input().split()
i = 0
for element in m:
    m[i] = int(element)
    i = i + 1
k = 1
sum = m[0]
for i in range(1, 10):
    k = k + 1
    sum = sum + m[i]
    if m[i-1] == 2 and m[i] != 2:
        sum = sum - m[i-1]
        k = k-1
print(int(sum/k))

Пример:
Введите оценки:
5 5 5 5 5 5 5 5 5 2 
4
Ответил Чайка2281
0
огромное спс
Ответил petyaGavrikov
0
пожалуйста
Новые вопросы