язык - Pascal. даны натуральное число n и последовательностьa1, ...., an. Составьте программу,которая находит среднее арифметическое тех элементов последовательности, которые кратны 3 и не кратны 9
Ответы на вопрос
Ответил kavko903
0
var
n, i, s, a, k: integer;
begin
readln(n);
s := 0;
k := 0;
for i := 1 to n do
begin
read(a);
if (a mod 3 = 0) and (a mod 9 <> 0) then
begin
inc(k);
inc(s, a);
end;
end;
write(s div k);
end.
n, i, s, a, k: integer;
begin
readln(n);
s := 0;
k := 0;
for i := 1 to n do
begin
read(a);
if (a mod 3 = 0) and (a mod 9 <> 0) then
begin
inc(k);
inc(s, a);
end;
end;
write(s div k);
end.
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Алгебра,
9 лет назад
Математика,
9 лет назад
Обществознание,
10 лет назад
Биология,
10 лет назад