y=1^1+2^2+3^3+...n напишите программу
Ответы на вопрос
Ответил alex44170
0
type
Tmas = array [1..100] of longint;
var
m: Tmas;
i, j, proiz, N, sohr: longint;
begin
proiz := 0;
readln(N);
for i := 1 to N do
begin
readln(m[i]);
sohr := m[i];
for j := 1 to sohr - 1 do
begin
m[i] := m[i] * sohr;
end;
proiz := proiz + m[i];
end;
writeln(proiz);
end.
Tmas = array [1..100] of longint;
var
m: Tmas;
i, j, proiz, N, sohr: longint;
begin
proiz := 0;
readln(N);
for i := 1 to N do
begin
readln(m[i]);
sohr := m[i];
for j := 1 to sohr - 1 do
begin
m[i] := m[i] * sohr;
end;
proiz := proiz + m[i];
end;
writeln(proiz);
end.
Новые вопросы
Другие предметы,
2 года назад
Математика,
7 лет назад
Математика,
9 лет назад
Математика,
9 лет назад